Skip to content

Ignore CVE on poetry and its transitive dependencies (1.22) - #4083

Open
sbrunner wants to merge 1 commit into
1.22from
ignore-snyk-cve-poetry
Open

sbrunner wants to merge 1 commit into
1.22from
ignore-snyk-cve-poetry

Conversation

@sbrunner

@sbrunner sbrunner commented Nov 8, 2026

Copy link
Copy Markdown
Member

Summary

Add Snyk policy files .snyk and ci/.snyk on the 1.22 stabilization branch to ignore the poetry/dulwich/filelock/virtualenv advisories that cannot be fixed on this branch, and stop the GHCI audit from re-applying the unresolvable Poetry >= 2.3.4 pins.

Context

Implementation Details

  • .snyk and ci/.snyk ignore 31 advisories: 2 on poetry (fix needs poetry>=2.3.x, blocked by the tweak plugin), 7 on dulwich (poetry requires dulwich<0.23.0), 13 on filelock (virtualenv requires filelock<4.0.0), 9 on virtualenv (poetry requires virtualenv<21.0.0).
  • No change to the requirements files: with these ignores the Snyk auto-fix will no longer produce the conflicting pins.

Impact/Risks

  • The ignored advisories stay unpatched on 1.22 until end of support. They affect only the CI/packaging tooling (requirements.txt / ci/requirements.txt installed in the Docker build stage), not the application runtime dependencies exported from poetry.lock.
  • Once merged, Audit Snyk check/fix 1.22 #4079 should be regenerated by GHCI without the conflicting pins (or can be closed).

…ith used Poetry version

The Snyk fix pinned poetry>=2.3.4 in ci/requirements.txt and bumped
poetry to 2.3.4 in requirements.txt, but poetry-plugin-tweak-dependencies-version
1.5.7 requires poetry<2.1.0, and pip failed with ResolutionImpossible.

The poetry upgrade is blocked by the plugin incompatibility, and while
poetry stays at 1.8.5, the following transitive dependencies cannot
be upgraded to their fixed versions:
- dulwich: poetry requires dulwich<0.23.0, the fixes need dulwich>=1.1.0
  (SNYK-PYTHON-DULWICH-17054926/17054927/17266106/18016337/20416729/20416732/22220108)
- virtualenv: poetry requires virtualenv<21.0.0, the fixes need
  virtualenv>=21.7.11
  (SNYK-PYTHON-VIRTUALENV-20335491/20335492/20335493/20335500/21282339/21282342/21282424/21282484/21282509)
- filelock: virtualenv requires filelock<4.0.0, the fixes need filelock>=4.0.9
  (SNYK-PYTHON-FILELOCK-21280750/21280753/21280754/21280755/21280756/21280759/21280760/21280761/21689161/21689162/21802489/21802490/21802520)
- poetry itself: Plugin not compatible with new Poetry version
  (SNYK-PYTHON-POETRY-15873752/16122096)

Drop the Snyk pins from ci/requirements.txt and requirements.txt and
ignore those advisories in .snyk and ci/.snyk, following the same policy
already applied on the 1.21 branch.

Failing CI: https://github.com/camptocamp/tilecloud-chain/actions/runs/42282692329/job/128115474462
Audit logs: https://geoservices-int.camptocamp.com/github/logs/3302538
@sbrunner sbrunner added the security vulnerability Security fixes label Nov 8, 2026
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant